Equipment/Laser Cutter Inkscape

From Makespace
Jump to: navigation, search

Inkscape tricks

A selection of hints to get the best out of Inkscape with our laser cutter. This applies to Inkscape 0.48.4.x and later, if you have an earlier version you should upgrade.


Page and grid setup

Set the default units (file->preferences) to mm. Then design everything in mm. These are preserved in dxf (choose mm as the units when saving) and you won't have to resize in the laser software.

At the same point you can create a grid, I use a 1cm grid with 1mm minor lines - select the 'Grids' tab and click 'New' to create a new rectangular grid, for the one I use set units to mm, spacing to 1 and major grid line every 10. I change the colours so I can see the major grid lines even when zoomed in fully.

Now save your document as "MyDefaultInkscapeDocument" and use it to start every project you work on :)

This is a (zipped) default inkscape document (mm as default and 1mm/1cm grid) File:DefaultInkscape01.zip

Preferences setup

Interface -> Grids. Set to origin 0, Spacing 1mm, major grid ever 10 (as above for the default document)

Behaviour -> Steps. This is a personal preference but I (Mat) prefer Arrow Keys Move By to 0.5mm. With a 1mm grid and 0.5mm nudging I get a 1mm grid with optional 0.5mm positioning. Inset/Outset I set to 0.075mm which matches half the laser cutter kerf.

Version 0.91

0.91 is latest and greatest. It very occasionally crashes (PC) compared to previous version (rock steady). Worth upgrading. Has newer image tracing options, but best of all, you can put formulae into its number boxes. So if your circle is as 0.543 mm and you want to move it right 1mm you can edit it to 0.543+1 mm and it sorts it all out for you. Also *2, /2, etc are handy for scaling.

General hints

Use fill and don't use stroke (turn it off each time you create a shape). Stroke paths show the thick outline, and this confuses the sizing and bounding box for laser cut things. Fill mode for shapes makes everything work better. For shapes with holes, make it show self intersections as holes. This is closest to what a laser cutter will do. Menu: Object -> Fill and Stroke. Right hand side, click the "Fill" tab. Click the icon second from the right, looks a bit like a heart with a hole in it.

Grids

By default Inkscape won't actually use the grid, the buttons on the far right allow you to enable snap (first button from the top), to bounding boxes (second from top and subsequent four) and path nodes (the next group down). If you're not getting the snapping behaviour you expect play with turning these on. When snapping to path points it'll use the point closest to your mouse when you're dragging, so it matters where on the path you click!

I find it easiest to get a sense of how big the piece is going to be if I set the page dimensions to those of the laser cutting bed, i.e. 900x600mm. You can do this from 'File->Document Properties...' then entering a custom size, remember to change units to mm.

Outline mode

Inkscape can be put into outline mode, allowing you to see objects which have neither stroke nor fill. This is great because adding a stroke changes the dimensions of the object (slightly, but potentially enough to matter) and adding a fill makes it hard to see what you're doing. Select from 'View->Display Mode->Outline'. As an alternative a default fill with opacity of 10% works nicely when creating compound objects. Turning off stroke for each shape achieves the same result (make sure you give it a fill colour so you can still see it...)

Text on a path

Easy to do, create a path, create some text and use the 'Text->Put on Path' menu item. With the text selected you can use the letter and word spacing controls to get the text to completely fill the path (I needed this for the plaque as we wanted the lists of names to butt up to each end of the shape). At this point the text and the path are coupled together, so while you can move the text away if you delete or change the path it'll alter. To get outlines ready for the cutter select the text object and do 'Path->Object to Path', you can then delete the original path object used to flow the text.

Rounded rectangles

If you try to use these the cutter will largely ignore them. Use the 'Path->Object to Path' to convert them into a generic path before exporting. Same for all boxes and circles.

Alternatively, enable the "use ROBO-Master type of spline output" (an option during saving) if your version of Inkscape supports it.

Dashed paths

The laser won't pay any attention to stroke styles you set in Inkscape. Recent versions, however, include an extension under 'Modify Path -> Convert to Dashes' which will render whatever stroke style you've selected.

Engraving text

Regular fonts used by Inkscape and everything else are outline fonts, that is to say they're defined as a filled shape. When used by the laser cutter the laser will cut the outline of the font, which looks great for large characters but often very badly (and slowly) for small typefaces. There's an extension at http://www.evilmadscientist.com/2011/hershey-text-an-inkscape-extension-for-engraving-fonts/ which allows for the use of engraving fonts where the font is defined in terms of the path used by the cutting tool rather than an outline.

Note - the version of the library at that link is broken with modern (0.48.4) versions of Inkscape, I've fixed the problem and uploaded a patched version to https://dl.dropboxusercontent.com/u/70831580/HersheyText.zip

Exporting

In the latest version of inkscape you have an option from 'File->Save As' to save as 'Desktop Cutting Plotter (AutoCAD DXF R14)'. With the default options this seems to work perfectly with the laser, dimensions are preserved etc. If you don't have this option upgrade your version of inkscape, it appeared some point over the last month or two.

Note, 'default options' means export unit is set to mm.